Author Topic: 500 Internal Server Error  (Read 834 times)

0 Members and 1 Guest are viewing this topic.

Offline egaeus

  • Newbie
  • *
  • Posts: 3
500 Internal Server Error
« on: October 20, 2014, 12:39:22 AM »
Okay, I'm slightly reluctant to ask, because I'm sure I'm doing something really obviously wrong, but I'm having no luck getting Form2email to work. I'm getting 500 Internal Server Error (The server encountered an internal error or misconfiguration and was unable to complete your request.)

I have the script set up as:

my $script_name              = 'emailform.pl'; (this is what I called it on the server.)
my $HTML_thankyou            = 'http://www.egaeuspress.com/testscreen2.html';
my $to                       = 'egaeuspress@gmail.com';
my $from                     = 'egaeuspress@gmail.com';
my $mailprog                 = '/usr/sbin/sendmail';
my $subject                  = 'Web Enquiry';

The sendmail and path to perl are (my server says) correct. I'm sure I'm doing something quite obviously wrong.

You can still see the test screen I made at  http://www.egaeuspress.com/testscreen2.html.

Thank you in advance.

Offline Jason

  • Administrator
  • Hero Member
  • *****
  • Posts: 1018
    • slipdex
Re: 500 Internal Server Error
« Reply #1 on: October 20, 2014, 02:51:05 PM »
The link to the test screen is simply your thank you page which does not give any information. Usually a 500 error has to do with your permissions on the file on your server or your path to perl. Look at the FAQ here: http://www.ezscripting.com/form2email/faq.htm#What%20is%20%22Error%20500%20Internal%20Server%20Error%22?

Make sure you follow the example and directions on the the instructions page: http://www.ezscripting.com/form2email/instructions.htm. See if you can get it working by using the actual files that came with the download. Using those files with the setup it came with should work on your server if you ahve the CHMOD and paths set correctly.

Jason
Founder of www.slipdex.com

Offline egaeus

  • Newbie
  • *
  • Posts: 3
Re: 500 Internal Server Error
« Reply #2 on: October 21, 2014, 12:01:55 AM »
Sorry. Yes. My fault. The link to the test screen should have been: http://www.egaeuspress.com/testscreen1.html. Is that any use?

As far as I can see the paths are all set correctly.

Offline Jason

  • Administrator
  • Hero Member
  • *****
  • Posts: 1018
    • slipdex
Re: 500 Internal Server Error
« Reply #3 on: October 21, 2014, 04:55:22 AM »
Are the permissions set correctly for the files in the server? CHMOD 755 or 777?

Jason
Founder of www.slipdex.com

Offline egaeus

  • Newbie
  • *
  • Posts: 3
Re: 500 Internal Server Error
« Reply #4 on: October 23, 2014, 07:57:25 AM »
Got it sorted.
Server's been giving me the runaround.
Thanks very much for your help.