Author Topic: Server error  (Read 4844 times)

0 Members and 1 Guest are viewing this topic.

Offline js-photos

  • Newbie
  • *
  • Posts: 14
Server error
« on: August 07, 2006, 06:08:21 PM »
Greetings,

I have installed the gallery script on another server with no problems. I have been working on installing it on a new project and different webserver and get a server error. This is the entry in the error log:

gd-jpeg: JPEG library reports unrecoverable error: Empty JPEG image (DNL not supported)

Is this a problem with my settings or could it be a webhost issue? Thanks for providing such awesome scripts!

js-photos

Offline EZ

  • Hero Member
  • *****
  • Posts: 1081
    • Babelnotes.be
Re: Server error
« Reply #1 on: August 07, 2006, 06:15:49 PM »
That error is quite unknown to me.  Do check with your host on whether they have GD (for Perl - that is important) fully installed.

The error message is not in the script, so it comes from the GD module.  it means that somewhere in the module some empty object is returned.  I do not know why.  It might mean an incomplete install or something else.  Did you check with other images ?  Just to make sure that GD is not choking on some corrupt image ?

Offline js-photos

  • Newbie
  • *
  • Posts: 14
Re: Server error
« Reply #2 on: August 08, 2006, 07:35:40 PM »
Thanks for your suggestions. I did try multiple images and while the original image uploaded and it looked as though the thumbnails were created, they were empty and showed 0kb. It was after I submitted  to create the record and upload that I would get the server error.

I checked my hosts installation list and it says GD for perl is installed. I just submitted a tech ticket with the error and asked them to check the installation. Thanks again for your help and I will keep you posted on what I find out. Take care.

js-photos

Offline js-photos

  • Newbie
  • *
  • Posts: 14
Re: Server error
« Reply #3 on: August 10, 2006, 09:58:15 AM »
Here is the reply from my host tech support.

Yes, it seems that GD causing this trouble (If disabled, it started to work - check it now). Please let us know exact version of GD required on the server and vendor's comment on the following errors:

Use of uninitialized value in concatenation (.) or string at mods.cgi line 60.
Use of uninitialized value in concatenation (.) or string at mods.cgi line 60.
Use of uninitialized value in concatenation (.) or string at mods.cgi line 60.
Use of uninitialized value in concatenation (.) or string at mods.cgi line 60.
Use of uninitialized value in numeric lt (<) at mods.cgi line 144, line 24726.
Use of uninitialized value in substitution (s///) at mods.cgi line 180, line 24726.
Use of uninitialized value in concatenation (.) or string at mods.cgi line 181, line 24726.
Use of uninitialized value in concatenation (.) or string at mods.cgi line 181, line 24726.
Use of uninitialized value in substitution (s///) at mods.cgi line 180, line 24726.
Use of uninitialized value in concatenation (.) or string at mods.cgi line 181, line 24726.
Use of uninitialized value in concatenation (.) or string at mods.cgi line 181, line 24726.
Use of uninitialized value in substitution (s///) at mods.cgi line 180, line 24726.
Use of uninitialized value in concatenation (.) or string at mods.cgi line 181, line 24726.
Use of uninitialized value in concatenation (.) or string at mods.cgi line 181, line 24726.
Use of uninitialized value in substitution (s///) at mods.cgi line 180, line 24726.
Use of uninitialized value in concatenation (.) or string at mods.cgi line 181, line 24726.
Use of uninitialized value in concatenation (.) or string at mods.cgi line 181, line 24726.
gd-jpeg: JPEG library reports unrecoverable error: Empty JPEG image (DNL not supported)
[Thu Aug 10 08:11:34 2006] [error] [client 195.85.219.102] Premature end of script headers:

(End of Tech Support Comment)

Like support said it functions correctly with GD disabled (as you have also stated on Galleryscript.net) Will it create any problems to leave it disabled or was the script programmed to function with a specific version of the Perl GD module (ie 1.1 or 2.0 etc)?

I greatly appreciate your help and patience as well seek the solution. Take care!

js-photos

Offline EZ

  • Hero Member
  • *****
  • Posts: 1081
    • Babelnotes.be
Re: Server error
« Reply #4 on: August 10, 2006, 10:57:24 AM »
Could I have a link to your test system ?

Offline EZ

  • Hero Member
  • *****
  • Posts: 1081
    • Babelnotes.be
Re: Server error
« Reply #5 on: August 10, 2006, 11:04:01 AM »
and btw:

disabling GD will not give you any problems, other than the aspect ratio on thumbnails might be a bit strange sometimes (you'd have to check).  If the uploaded images are very big, then not using GD will also slow down loading time of a thumbnail overview page a bit, as the browser is loading the full images just to show them smaller.

You might want to try for yourself and see whether that gives you acceptable results.

However, if GD is enabled on the server then the script will autodetect it and try to use it.  So, to force the script into NOT using GD when it is enabled on the server, add the red line:

Quote
my $use_GD; # set to 0 to fully disable use of GD
my $GDinstalled;
BEGIN {
$GDinstalled = eval { require GD };
if ($GDinstalled != 0) {
$use_GD = 1;
}
else {$use_GD = 0;}
}

$use_GD=0


Offline js-photos

  • Newbie
  • *
  • Posts: 14
Re: Server error
« Reply #6 on: August 10, 2006, 12:13:21 PM »
Here is the link.

http://westrimdesigns.com/users/templates/one/cgi-bin/images.pl

The login is still at the default.

At the current time my host tech support has GD disabled. Thanks again for your help!

Offline EZ

  • Hero Member
  • *****
  • Posts: 1081
    • Babelnotes.be
Re: Server error
« Reply #7 on: August 10, 2006, 01:05:11 PM »
ehm... with GD disabled I cannot really test much...

What version of GD do you have btw ?

Offline js-photos

  • Newbie
  • *
  • Posts: 14
Re: Server error
« Reply #8 on: August 10, 2006, 01:26:46 PM »
Sorry about that...I thought about that after I had posted. I have a request for GD to be re-enabled.

They just told me the version was GD v.2.0.28

Thanks!!

Offline EZ

  • Hero Member
  • *****
  • Posts: 1081
    • Babelnotes.be
Re: Server error
« Reply #9 on: August 10, 2006, 02:15:48 PM »
I have been googling on this one as I cannot reproduce on my own systems.  From what I can make from it, most explanations boil down to a problem with the Perl GD module (wrongly installed or compiled or ...).

I am afraid I am of no much help on this issue.

Is running the script without GD support on that specific server an acceptable workaround for you?

Offline js-photos

  • Newbie
  • *
  • Posts: 14
Re: Server error
« Reply #10 on: August 10, 2006, 02:46:57 PM »
I don't think it would be a problem running the script without the GD support. I may just have to limit the number of thumbnails I put on a page. I really do appreciate your time and help! If anything changes I will let you know. Thanks again!

js-photos

Offline EZ

  • Hero Member
  • *****
  • Posts: 1081
    • Babelnotes.be
Re: Server error
« Reply #11 on: August 10, 2006, 02:52:48 PM »
Sorry I cannot help any more than that.

Hint : keep the size of your uploaded images reasonable (not like your test setup images).  That will improve performance  ;)

Offline js-photos

  • Newbie
  • *
  • Posts: 14
Re: Server error
« Reply #12 on: August 10, 2006, 07:30:56 PM »
No problem...You have been more than helpful and I still love the script! Thanks again for all of your help and have a nice day.

js-photos

Offline js-photos

  • Newbie
  • *
  • Posts: 14
Re: Server error
« Reply #13 on: August 16, 2006, 07:14:18 AM »
Greetings Again,

I'm still hashing things out with my host company as I am not giving up hope to use the script the way it was programmed to function. They just asked me what  GD/libgd version is required for the application? Thanks again for all of your help and awesome products!

js-photos

Offline EZ

  • Hero Member
  • *****
  • Posts: 1081
    • Babelnotes.be
Re: Server error
« Reply #14 on: August 16, 2006, 08:01:18 AM »
Hi,

On my local machine it's GD 2.30.  I can't check on my host, but I saw on CPAN that 2.34 is the latest version.  I guess that is what you want.  I do not know for libgd?